Print Page | Close Window

Nice day to change the Av's battery

Printed From: Colorado Av Club
Category: Colorado Av Club Joe's Bar & Grill
Forum Name: Av Stories
Forum Discription: Stories Related To Avalanches
URL: http://www.coloradoavclub.com/forum/forum_posts.asp?TID=165
Printed Date: 19 Oct 2019 at 7:35am
Software Version: Web Wiz Forums 8.04 - http://www.webwizforums.com


Topic: Nice day to change the Av's battery
Posted By: JoeSpicoli
Subject: Nice day to change the Av's battery
Date Posted: 11 Nov 2007 at 9:50pm
Well, I hadn't really had any problems with my '02 Av so far...until today.  It wouldn't start this afternoon when I went to leave.  It was deader than a door nail.

So I start to troubleshoot the issue.  I had an idea that maybe the battery terminals were getting corroded because every once in a while, I'd start the Av up and the radio would be locked.  Ya know, when you turn the security feature on and you lose power, the radio won't function and says "LOC" on the display?  Curious, that was.

I clean the battery terminals and still nothing.  Then I get my meter out.  Going directly to the terminals, I have like 11.7 volts, plus the "Green Eye" says the battery is charged.  So I re-clean the terminals, even using some Q-tips with baking-soda water to get inside the terminal.  Still no dice.  So I test the voltage with the terminals connected.  I get about 4.7 volts.  Ugh.  What could it be?

Well, it could be that the positive battery terminal broke/rotted out.  Attached is a pic.

Luckily, my girlfriend doesn't live too far away and gave me a ride down to Autozone to pick up another battery.

So I am back in business.  I tell you though, my Av has been really nice to me.  I have 75K miles on it and the battery is the only "trouble" it has given me.  Knock on wood.  Before I got my meter out, I was tempted to call Ken; I was just at a loss for what was wrong.  I was thinking ignition switch at first.

-Joe




-------------
2002 Indigo Blue Z-71



Replies:
Posted By: avalanchuck
Date Posted: 12 Nov 2007 at 9:16am
Oh sure rub it in!  I'd have to say other than my instrument cluster and fuel pump problems my Av has held up well too!

-------------
2003 Light Pewter Metallic Z71 WBH


Posted By: beercrazy
Date Posted: 13 Nov 2007 at 11:55pm
Hell Im still tryin to save the $450 to get a new EBCM for my Av.. As soon as I have a bit of cash stashed away, something comes up (another light mod). Id rather go new on this part but its looking like I may have to break down and try to find a used one, with winter coming on and all the snow it would be nice to have the ABS active again.

-------------
Whats you AVitude telling you????


Posted By: justjr
Date Posted: 14 Nov 2007 at 5:52am
I'll make some calls for you at work Ken.
I might be able to find one for you through our collision distributers.


-------------
Just Drive Man!!!


Posted By: beercrazy
Date Posted: 14 Nov 2007 at 10:04am
coolnes...that would be fantabulous.......thanks Jr.

-------------
Whats you AVitude telling you????


Posted By: chadstr
Date Posted: 14 Nov 2007 at 5:16pm

Both you Joe and Chuck are bragging, I would put my list of stuff on here but I would probably run out of space. Its a lot shorter list to do what hasn,t needed worked on. Im glad you got your rig going Joe.



-------------
Yea, My modifications on my truck are worth more than my truck.



Print Page | Close Window

Bulletin Board Software by Web Wiz Forums version 8.04 - http://www.webwizforums.com
Copyright ©2001-2006 Web Wiz Guide - http://www.webwizguide.info